No announcement yet.

Reinstalled JB4 in 2019 GLC63 - Going into limp mode at WOT in Maps 1& 2 - Any ideas?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Reinstalled JB4 in 2019 GLC63 - Going into limp mode at WOT in Maps 1& 2 - Any ideas?

    I ran my JB4 in my GLC63 for almost two years and never threw a single code. I had to remove it to get some recall work down at the dealer and just reinstalled it today. After install, I updated to the latest firmware. Everything looked good after initial startup, but once I get into the throttle, I am getting a CEL. Codes shown are P0300, P0600 and P42BB. I used to run all day long in Map 2 (93 octane) but I'm getting the CEL in Map 1.

    I know I've been spoiled since I've never had an issue before, but I have no idea what could be going on. Hoping the attached logs may provide some insights to the experts. Any ideas?
    Attached Files

  • #2
    And for confirmation, the connectors I don't use, I should leave disconnected, is that right? For example, the black and white connector, I don't connect to itself - i just leave both ends disconnected, is that right? Just trying to make sure that's not my issue.


    • #3
      I haven't received any responses to my messages, but there have been quite a few views so I thought I'd provide an update. Don't want to jinx myself, but it seems Terry sent a remote blessing to my car. I ran it hard on Map 1 yesterday afternoon and again this morning with no issues. I have no idea what to think. I'm going to stay in map 1 and continue testing, then will post logs and go from there before trying Map 2. As I said before, I ran Map 2 for over a year without issues, but want to make sure everything is good before I try it again.